Prerequis systemes

Système minimale requis

Il s’agit des exigences minimales qui doivent être satisfaites pour que notre intégration fonctionne et puisse être maintenue.

EXIGENCES EN MATIÈRE D’OUTIL DE SYNCHRONISATION

  1. Exigences en matière d’installation
  2. Pare-feu :

(1) Doit autoriser le trafic sortant sur le port 22000 pour la connexion SFTP
(2) Doit mettre sftp.beanworks.com ou sftp.sageapa.com sur liste blanche
Nous vous encourageons à utiliser les noms de domaine ci-dessus. Nous ne pouvons pas garantir que les adresses IP resteront inchangées

  1. Programme de mise à jour automatique :
    lors de votre connexion à la plateforme SaaS, et afin de maintenir votre intergiciel à jour avec notre plateforme, nous disposons d’un outil de mise à niveau qui doit être autorisé à :
    (1) S’exécuter sur votre système
    (2) Atteindre nos systèmes et déterminer si une mise à jour est en attente
    (3) Mettre à jour notre outil SyncTool sur votre système

Liste blanche du programme de mise à jour automatique : si vous souhaitez restreindre les adresses IP que le programme de mise à jour automatique peut atteindre via votre pare-feu, utilisez les entrées ci-dessous :

  • 95.145.0/24
  • 95.146.0/23
  • 92.84.0/22
    Notre programme de mise à jour automatique doit être autorisé à atteindre nos serveurs pour déterminer si des mises à jour sont en attente pour l’outil SyncTool de notre client.

Exécution en tant qu’administrateur : si vous avez besoin d’une confirmation UAC lors du lancement d’un produit Sage, il peut s’avérer nécessaire d’activer l’exécution de l’outil SyncTool en tant qu’administrateur pour contourner la boîte de dialogue UAC.

  1. Admin ERP :
    notre logiciel doit pouvoir lire vos fichiers de données ERP et écrire à l’intérieur pour les fonctionnalités AP, SYS et PO. Si vous ne savez pas quelles autorisations sont nécessaires pour créer un utilisateur et activer la fonctionnalité dont nous avons besoin, nous vous recommandons fortement de saisir un utilisateur Admin ERP pour les identifiants ERP dans l’outil SyncTool.
  2. Navigateur
    Beanworks fonctionne mieux avec des navigateurs modernes tels que : Google Chrome, Mozilla Firefox, Safari et Microsoft Edge. Nous vous recommandons d’utiliser la version la plus à jour de votre navigateur car certaines nouvelles fonctionnalités de Beanworks risquent de ne pas être disponibles si la version de votre navigateur est obsolète.

 III. Version de votre logiciel de comptabilité :
l’intégration de Beanworks à votre logiciel de comptabilité nécessite l’installation de votre ERP sur la version la plus à jour (-2).

  1. Exigences spécifiques de l’ERP/du logiciel de comptabilité
  2. QBD 2013 – 2018
  • Version Windows minimale : Windows Server 2008
  • Version .NET : 4.5
  • RAM : 4 Go
  • Disque dur : 400 Mo
  • Exigences spécifiques à l’ERP : l’outil doit être autorisé comme application tierce pour accéder aux fichiers de l’entreprise en tant qu’administrateur.
  1. QBD 2019
  • Version Windows minimale : Windows Server 2016, Windows 7, 10
  • Version .NET : 4.7.1
  • RAM : > 4 Go
  • Disque dur : 400 Mo
  • Exigences spécifiques à l’ERP : l’outil doit être autorisé comme application tierce pour accéder aux fichiers de l’entreprise en tant qu’administrateur. Aucune autre version de QuickBooks ne peut être installée sur le même serveur/réseau